Trouble: NFS via TCP

Julian Stacey jhs at
Wed Nov 15 13:04:10 UTC 2006

Oliver Fromme wrote:

>  > Using a normal UDP mount I had eratic come & go problems with amd
>  > until I added to rc.conf
>  > 	nfs_server_flags="-u -t -n 10"
>  > Turns out I had too few. 10 fixed it.
> Thanks for the suggestion, but I don't think it applies
> here.
> I'm using the default (-n 4), but this is the only mount
> from localhost, so that should be sufficient.
Unless some other host mounts on to yours & occupies slots,
maybe driven by a remote { amd or MS equivalent } (long shot, admitted).

>  Besides,
> the same problem occurs when trying to mount from a NetApp
> filer.

MS ?  I'm clueless :-)

> Also, I don't have "erratic come & go problems",
> but the mount(8) command simply hangs right from the start.

Good, intermittents are harder to chase.
I had a bad solder joint on a coax BNC once, intermittent, pings
worked, some protocols broke, & had an electolytic die in a UTP hub
power that similarly caused intermittents through low voltage.

> I'm not using amd, if that matters (I don't think it does).

Agreed. (Just mentioned it in case you were doing anything unusual,
eg my hosts mount themselves occasionaly, to allow transparent host
independence/ orthogonality of scripts).  More a question if other
host mounting yours. I recall X terminals can try unusual boot
methods inc NFS, maybe other devices eg TCP printer spoolers to
parallel converters too etc ?

Maybe if you remove all but your 2 hosts on to a seperate net
briefly for a test to see if some weird 3rd party problem ?
(a bit like ripping spare cards out of a problematic PC).

> Since I weren't able to track this problem down, I now tend
> to think that it's a bug in the NIC (either broken hardware
> or a bug in the bge(4) driver) that makes it break TCP NFS
> packets somehow.  I don't have any other explanation.

I think you've already checked no ipfw in way either end (your old
mail not to hand).  Sometime my probs come down to eg: bad cmos
battery on a cold standby gate I power up, timed masters off the
spare gate, zaps internals, rdist of configs fails, named fails,
NFS fails. All 'cos I turned a box on :-)

Good luck.

Julian Stacey.  BSD Unix C Net Consultancy, Munich/Muenchen
Mail Ascii, not HTML.		Ihr Rauch = mein allergischer Kopfschmerz.

More information about the freebsd-stable mailing list