6-STABLE oddity

Jaime Bozza jbozza at qlinksmedia.com
Mon Nov 13 15:25:36 UTC 2006

> Download, burn to CD and run http://www.memtest86.com/
> Usually problems of this sort are faulty ram.
> I had a buddy getting odd errors on copying files that happenned at
> random.
> Turned out to be bad ram too.

I recently had this same problem with a recent 6-STABLE and thought the
same thing.  Ran memtest for over 48 hours and never came up with any
errors.  I would cvsup source and run an md5 check to compare with
another "known good" system and seemed to always have 1-2 files bad.  It
seemed to always be just 1 bit off.

Tried swapping cables, cards (SCSI), etc.  The system was running
gmirror on two 18G SCSI drives using an Adaptec controller.  If I
disabled the 2nd drive, I didn't have a single problem after a ton of

Turned out that I hadn't formatted the 2nd drive using the Adaptec
tools.  The drives had been out of service for about 3 years.  Once I
went through a format/verify I wasn't able to duplicate the problem no
matter what I tried.

So, RAM is definitely the easiest thing to test but keep in mind that
there are other areas that may also cause an issue.

Jaime Bozza

More information about the freebsd-stable mailing list