ULE-scheduler helped (Re: new em-driver still broken)

Mikhail Teterin mi+kde at aldan.algebra.com
Sat Nov 4 16:35:29 UTC 2006

On Tuesday 31 October 2006 20:41, Jack Vogel wrote:
= I still think it looks like some kind of scheduler issue going on
= here, so maybe this is something to check.

Ok. First I tried to cvs the sys/dev/em back to 6.1 -- the new kernel
had the same problems...

Then I tried to change the 'PCI latency timer' in the BIOS -- from
the minimum of 32 to the maximum of 360. Same problems.

Then, finally, I decided to give the ULE-scheduler a try -- and things
seem to work just fine (with polling enabled on the interface)...
The dump has completed -- in 7 hours or so...

Could this (failure of the BSD44 scheduler) be due to my using slightly
different CPUs (Opteron 244 in the first slot and 246 in the second)? I
thought, BIOS/motherboard take care to "downgrade" the second one to
match -- according to the dmesg.boot, both processors are identified as:

	CPU: AMD Opteron(tm) Processor 244 (1800.01-MHz K8-class CPU)

But if the scheduler looks at some CPU-local register, it may, in some
cases, still think, it is running on 246?

To summarize, unless someone else continues to see em-related problems,
the current driver is fine, I guess...


More information about the freebsd-stable mailing list