Trouble with NFSd under 6.1-Stable, any ideas?

Howard Leadmon howard at
Tue May 23 06:59:57 PDT 2006

> > > If there are any thing I can provide to help tracking this down. 
> > > Please let me know. By the way, I tried with truss/kdump 
> to see what 
> > > happens when nfsd eats lot of CPUs, but in vain. They do 
> not return anything.
> > >
> > I tried your recipe on 7-CURRENT with locally exported fs, 
> remounted 
> > over nfs. I did not get the behaviour your described.
> As noted in my previous thread, I have another 6.1-RELEASE 
> nfs server, which does not have this problem.
> > Could you, please, provide the backtrace for the nfsd that eats the 
> > CPU (from the ddb). I think it would be helpful to get several 
> > backtraces (i.e., bt <nfsd pid>, cont, bt <nfsd pid> ...) 
> to see where 
> > it running.
> I'm afraid that I can not do that. Last time I tried breaking 
> into ddb (on 5.x), it hangs my serial console and the server 
> is miles away :-( . Perhaps we can ask Howard to do that?

 I am more than willing to do that, as this machine runs here with me, so if
needed I can easily get on a console, or perform a reboot.  Can one of you
shed a little light on exactly what I need to do, and how to do this?  I ask
as I have never used this ddb stuff, so not clue one on how to go about
getting the information your looking to find.  Guess I have been lucky, and
just never had an issue that took things to this level.

> > Also, just in case, does filesystem that is exported and shows 
> > problem, have quotas enabled ? One line of your fstab has 
> userquotas, other does not.

As to userquotas, I just tried accessing the NFS mounts here, as some have
filesystems with quotas, and some don't, and both are exibiting the exact same
problem.  So using quotas is for sure not the problem, or should I say not the
trigger to the problem.

> Regards,
> Rong-En Fan

Howard Leadmon

More information about the freebsd-stable mailing list