ipw(4) breaking under load

doug doug at fledge.watson.org
Sat May 20 15:10:27 PDT 2006

I am using ipw on thinkpad t42p. Last night while updating the ports tree I got 
an error which disconnected the cvsup. Restarting worked fine. I assumed it was 
signal strength or noise at the time. I will monitor this more closely. My 
recurring problem is all ssh connections are locked when the dhcp lease expires 
and the system is idle. I am not currently on the laptop so I can not document 
the versions I am using. I built the driver a few days ago and downloaded the 
Intel 2100 firmware at that time.

Other than the above it has worked fine for me.


On Sat, 20 May 2006, Ulrich Spoerlein wrote:

> Patrick Lamaizière wrote:
>>> is it just me, or is no one actually using ipw(4) under 6.1? Anyway, I
>>> set up a FreeBSD based AP using an ural(4) device. I'm connecting to it
>>> via laptop and ipw(4). This works fine, as long as you don't push it.
>>> Transferring some files via NFS gives me a lousy 100kB/s transfer rate,
>>> which quickly stalls and the connection wedges. Syslog reports:
>>> May 19 17:29:48 roadrunner kernel: ipw0: fatal error
>> I've got this error with the iwi driver too (Intel 2200 BG). But not often
>> (one or two times a week). It seems not related to the network load for me.
> Normal network traffic works just fine for me. Several SSH session, http
> traffic, pings etc.
> Only when pushing it, it quickly stalls.
> Ulrich Spoerlein
> -- 
> PGP Key ID: 20FEE9DD				Encrypted mail welcome!
> Fingerprint: AEC9 AF5E 01AC 4EE1 8F70  6CBD E76E 2227 20FE E9DD
> Which is worse: ignorance or apathy?
> Don't know. Don't care.

More information about the freebsd-stable mailing list