pxeboot with amd64 vs i386

Dmitry Morozovsky marck at rinet.ru
Thu May 18 07:34:04 PDT 2006

On Thu, 18 May 2006, Danny Braniss wrote:

DB> > DB> > At that point, lsdev shows the disk devices, but not the pxeboot "disk", which 
DB> > DB> > leaves me without a kernel, etc.  So something is different between the i386 
DB> > DB> > and amd64 disks, or maybe there's a problem with my BIOS.  I was wondering if 
DB> > DB> > anyone else had set up a similar configuration and had it work?
DB> > DB> > 
DB> > DB> > Robert N M Watson
DB> > DB> 
DB> > DB> I had similar experience, i recompiled a fresh pxeboot, and it's ok now.
DB> > 
DB> > Hmm, would you please point me to the right pxeboot? I tried both i386 and 
DB> > amd64 versions from 6.1-R ISOs as well as i386 version from April's RC.
DB> i compiled the one in the src of the 6.1-stable.
DB> 	/src/sys/boot/i386/pxeldr
DB> i took the easy road, cd /src; make buildkernel, and picked up pxeboot

Hmm, which architecture?

I just rechecked, and got the same error with mfsroot with all pxeboots and 
both i386 and amd64 distribs (I think boot/loader phase is the same for them 

D.Marck                                     [DM5020, MCK-RIPE, DM3-RIPN]
*** Dmitry Morozovsky --- D.Marck --- Wild Woozle --- marck at rinet.ru ***

More information about the freebsd-stable mailing list