megamgr on 6.1?

Brian Szymanski ski at
Tue May 9 14:15:35 UTC 2006

Oh, duh, it's been so long since I used linux binary emulation that I
forgot all about brandelf... Thanks Michael!

... But now that the binary is properly branded, I get a different error:
  Error opening terminal: xterm.
I get the same error for xterm-color, cons25, vt220, and everything else
I've tried... (and I know for a fact that TERM=xterm works on my linux
machines)... Any ideas?


> Brian Szymanski wrote:
>> Hi...
>> I saw this in the 6.1 release notes and eagerly upgraded:
>>   "The amr(4) driver now supports ioctl(2) requests necessary for Linux
>>   LSI MegaRaid tools on FreeBSD's Linux emulation environment."
>> However, when I pulled over a megamgr.bin binary from a linux machine,
>> and
>> try to execute it on my freebsd machine, I get:
>>   [root at ozelmo ~/src/megaraid]# ./megamgr.bin
>>   ELF binary type "0" not known.
>>   bash: ./megamgr.bin: cannot execute binary file
>> Has anyone got this working? What did they need? Any help would be
>> appreciated, as I'm seriously sick of megarc :)
>> Thanks in advance!
> Since it appears to require Linux emulation, have you tried branding the
> binary is a Linux ELF with brandelf(1)?
> -Proto

Brian Szymanski
Software and Systems Developer
Media Matters for America
ski at
skype: xbrianskix
aim:   xbrianskix

More information about the freebsd-stable mailing list