ssh: "Connection reset by peer" or "Corrupted MAC on input"

Michael Gerhards HM-Gerhards at
Sat May 6 12:35:05 UTC 2006


I have just installed FreeBSD/i386 6.1-RC2 on a AMD Athlon 64 X2 3800+,
Asus A8N-SLI Deluxe Motherboard and 2 GB RAM. The Motherboard has two
Ethernet-Ports for 1000BaseT which dmesg gives out as:
 skc0: <Marvell Gigabit Ethernet> port 0xa400-0xa4ff mem 0xd1004000-
 0xd1007fff irq 17 at device 12.0 on pci5
 skc0: Marvell Yukon Lite Gigabit Ethernet rev. (0x9)
 sk0: Ethernet address: 00:11:d8:ca:ed:43
 nve0: Ethernet address 00:11:d8:ca:e1:8b

I read about problems with the nve driver, so I only configured the skc0
device. It is connected to a 100MBit Hub, and all other computers in my
local networks have 100MBit card, too.

I tried to copy some larger files to the new system via scp from my old
Pentium2-300, running FreeBSD/i386 6.1-RC1. But scp ends this copying
at some (not predictable) place with either 
 "Received disconnect from 2: Corrupted MAC on input.  
 lost connection"
 "Write failed: Connection reset by peer
 lost connection"
(I ran scp on the old Pentium2 system).

Copying between my Pentium2 and the other computers in my local network
(all running at 100MBit full duplex mode) is without any problems.

What might be the reason for my problems? Is there a problem in the
support for my skc0 device? What could I do to solve my problems?

If you need more information about my hardware/systems just ask!

Many thanks in advance,


More information about the freebsd-stable mailing list