quota deadlock on 6.1-RC1

David Kirchner dpk at dpk.net
Thu May 4 23:59:36 UTC 2006

Here's how to reproduce the snapshot deadlock I'm seeing, with 6.1-RC2
cvsup'd as of 5 or 6 hours ago:

1) dd if=/dev/zero of=/usr/bigfile bs=1024 seek=209715200 count=0
2) mdconfig -a -t vnode -f /usr/bigfile
3) bsdlabel -w md0 auto
4) newfs -U md0a
5) fsck -v /dev/md0a # ^C this after a second or so, this makes the FS dirty
6) mount /dev/md0a /mnt
7) fsck -v -B /dev/md0a

in another window:
8) while true; do ls -al /mnt/.snap;sleep 1;done

It locks up every time for me, with no further disk activity.
Unfortunately, for some reason, my server console became unaccessable,
so I'm not able to get to the kdb prompt. If I can get to it later,
what should I run other than "show lockedvnodes" and "show threads"?
Also, can anyone else try these steps and verify if they cause the
same problem for you?

In my initial tests, filed in a PR, steps #1 and #2 were unnecessary
as I was working with real disks. The result is the same here. Still,
I am curious if anyone else can get the same result with a real disk
>=200GB in size. I am unable to duplicate it with a 20GB partition,
and I am not sure why.

David 'dpk' Kirchner

More information about the freebsd-stable mailing list