gareth bsd at lordcow.org
Thu Mar 30 15:31:45 UTC 2006

On Thu 2006-03-30 (08:54), Scot Hetzel wrote:
> 2. change to sub directory where FreeBSD builds ntpdate:
>     cd /usr/src/usr.sbin/ntp/ntpdate
>     make clean
>     make
>     make install
>     make clean

cool, thanx, i found that earlier with a 'locate ntpdate | grep Makefile'
and tried to run make but it gives:

root at cow:/usr/src/usr.sbin/ntp/ntpdate# make
Warning: Object directory not changed from original /usr/src/usr.sbin/ntp/ntpdate
cc -O -pipe  -I/usr/src/usr.sbin/ntp/ntpdate/../../../contrib/ntp/include -I/usr/src/usr.sbin/ntp/ntpdate/../ -DSYS_FREEBSD -DPARSE -DHAVE_CONFIG_H  -DOPENSSL  -c /usr/src/usr.sbin/ntp/ntpdate/../../../contrib/ntp/ntpdate/ntpdate.c
sh -e /usr/src/usr.sbin/ntp/ntpdate/../scripts/mkver ntpdate
Version <ntpdate 4.2.0-a Thu Mar 30 17:29:58 SAST 2006 (1)>
cc -O -pipe  -I/usr/src/usr.sbin/ntp/ntpdate/../../../contrib/ntp/include -I/usr/src/usr.sbin/ntp/ntpdate/../ -DSYS_FREEBSD -DPARSE -DHAVE_CONFIG_H  -DOPENSSL  -c version.c
cc -O -pipe  -I/usr/src/usr.sbin/ntp/ntpdate/../../../contrib/ntp/include -I/usr/src/usr.sbin/ntp/ntpdate/../ -DSYS_FREEBSD -DPARSE -DHAVE_CONFIG_H  -DOPENSSL   -o ntpdate ntpdate.o version.o /usr/src/usr.sbin/ntp/ntpdate/../libntp/libntp.a -lmd
cc: /usr/src/usr.sbin/ntp/ntpdate/../libntp/libntp.a: No such file or directory
*** Error code 1

Stop in /usr/src/usr.sbin/ntp/ntpdate.

and the same thing if i run 'make clean' first. there's a
directory called /usr/src/contrib/ntp/libntp/ , but there's
no libntp.a on the system.

More information about the freebsd-stable mailing list