4.9-4.11 receive network stack lockup

Stephen Clark Stephen.Clark at seclark.us
Mon Mar 27 03:34:25 UTC 2006

Stephen Clark wrote:

>Hi List,
>I am benchmarking freebsd 4.9, (also tried 4.11), two systems using 
>nttcp 1.47 from ports
>thru a 100mb switch with two realtek 10/100 nics.
>I have 50 gre tunnels going thru 50 vpn tunnels between the two machines 
>as well as
>quagga/ospfd with all addresses as neighbors.
>Using the following script I occasionally get in a state on the sending 
>machine where it can send data but not receive it. I have a console that 
>I run tcpdump on and I see packets go out but none come back, where on 
>the other machine I see the packets come an a response go back.
>Any ideas as to what could be happening?
>for ((i=1;i<51;i++ )); do nttcp -T -w48 -n 32768 10.1.1.$((i*2))& done
>freebsd-stable at freebsd.org mailing list
>To unsubscribe, send any mail to "freebsd-stable-unsubscribe at freebsd.org"
Hi List,

I am replying to my own message - I've discovered the following if I try
to ping localhost I get the following:
bash-2.05b# ping localhost
PING localhost ( 56 data bytes
ping: sendto: No buffer space available
ping: sendto: No buffer space available
--- localhost ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss
bash-2.05b# netstat -m
72/1312/5760 mbufs in use (current/peak/max):
         72 mbufs allocated to data
0/1214/1440 mbuf clusters in use (current/peak/max)
2756 Kbytes allocated to network (63% of mb_map in use)
0 requests for memory denied
0 requests for memory delayed
0 calls to protocol drain routines

but if i ping another machine:
bash-2.05b# ping
PING ( 56 data bytes
--- ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss

But if I tcpdump on I see:
$ sudo tcpdump -nli rl0
tcpdump: listening on rl0
22:30:29.701849 > icmp: echo request
22:30:29.701888 > icmp: echo reply
22:30:30.702799 > icmp: echo request
22:30:30.702833 > icmp: echo reply
22:30:31.703541 > icmp: echo request
22:30:31.703578 > icmp: echo reply
22:30:32.704331 > icmp: echo request
22:30:32.704365 > icmp: echo reply
22:30:33.183196 > isakmp: phase 1 I
ident: [|sa]
11 packets received by filter
0 packets dropped by kernel

The packet were going out on the wire - but the system was unable to get
the response - I am assuming because it was out of buffer space? Are
mbufs getting lost somewhere?

Is this a known problem?

More information about the freebsd-stable mailing list