: HEADSUP: new ath and hal - almost unusable?

Sam Leffler sam at errno.com
Thu Mar 9 04:19:27 UTC 2006

JoaoBR wrote:
> On Wednesday 08 March 2006 13:00, Sam Leffler wrote:
>> "simply stops" says little.  Are beacon frames transmitted?  Can you see
>> inbound traffic?  Is the ap configured in a bridge and can you see
>> outbound traffic from the wired interface?  What does ifconfig show for
>> the device?
> I agree but that is what it is, the communication is dead
> no traffic, no beacons no IP
> (I changed the antena stuff to see if the problem is in it but is not)
> the wired NIC is communicating normally to/from it's own IP address and it 
> shows ifconfig when the card is dead as:
>         ether 00:11:95:c2:2a:70
>         media: IEEE 802.11 Wireless Ethernet DS/11Mbps mode 11b <hostap>
>         status: associated
>         ssid casa channel 11 (2462) bssid 00:11:95:c2:2a:70
>         authmode OPEN privacy OFF deftxkey UNDEF powersavemode OFF
>         powersavesleep 100 txpowmax 36 txpower 63 rtsthreshold 2346 mcastrate 
> 1
>         fragthreshold 2346 -pureg protmode CTS -wme burst ssid HIDE apbridge
>         dtimperiod 1 bintval 100
>         options=49<RXCSUM,VLAN_MTU,POLLING>
>         inet netmask 0xfffffff0 broadcast
>         ether 00:04:75:72:40:c1
>         media: Ethernet autoselect (100baseTX <full-duplex>)
>         status: active
>>> no output with the card in debug mode
>> What is "no output"?  packets, console msgs?  what is "debug mode"?
>> Have you looked at the output of wlanstats to see if it gives you a
>> clue?  Can you see any frames with tcpdump or by sniffing from another
>> station?
> as I said no = no = none = nothing
> I can't see the AP anymore
>> So you have crypto configured; have you tried w/o?
> sure, no difference, same thing
>> the ap.  Then explain what clients are used or otherwise describe how to
>> reproduce your problem.  Once I have that I can try to reproduce the
>> problem here.
> acording to the above ifconfig output I set:
> 11b media DS/11Mbps mediaopt hostap ssid casa channel 11
> the clients are other atheros cards on XP and FBSD, ndis on FBSD, orinoco on 
> XP and FBSD, senao on XP and Fbsd
> Even if it does not help either, I change to boot releng_5 and the card works 
> fine and stable on the exactly same hardware

I'll have to see if I can reproduce this; never seen it.  It is very 
strange that there are no beacon frames and no traffic is being rx'd or 
tx'd.  This would seem to indicate interrupts have totally stopped 
(athdebug intr should show interrupts at least for the periodic events). 
  There should be some activitiy and/or error counters should show some 
problem.  At the very least tx traffic should either fill up the 
available hardware tx descriptors (in which case ifconfig would show the 
interface marked OACTIVE) or you should get errors.

Presumably you've tried different cards and/or hosts?  Does this happen 
on all your ap's or just one?


More information about the freebsd-stable mailing list