aaccli on recent conrollers?

Andrew N. Below defan at zenon.net
Wed Dec 27 08:31:07 PST 2006

Hi Vivek and oths...

----- Original Message ----- 
From: "Vivek Khera" <vivek at khera.org>
To: "FreeBSD Stable" <freebsd-stable at freebsd.org>
Sent: 10 ноября 2006 г. 19:42
Subject: aaccli on recent conrollers?

> I have just built a new SunFire X4100 server with an Adaptec 2230SLP
> RAID card using FreeBSD 6.2-PRE kernel (from September 20).
> Everything is working extremely well except I cannot run the aaccli
> utility on this controller. When I try to open the controller, it
> gives this error:
> Command Error: <The current AFAAPI.DLL is too old to work with the
> current controller software.>

The same error I get with Adaptec SATA RAID 2420S (aac0 controller
device, aacdX volume devices) with latest controller firmware.

I have just tried to install aacu.ko module from original Adaptec's
drivers, but still got no success:

aacu0: <Adaptec SATA RAID 2420SA> mem
0xb8a00000-0xb8bfffff,0xb8c00000-0xb8c00fff irq 24 at device 3.0 on pci6
aacu0: New comm. interface enabled
aacu0: Adaptec Raid Controller 2.0.7-1
aacdu0: <RAID 1 (Mirror)> on aacu0
aacdu0: 238289MB (488015872 sectors)
aacdu1: <Volume> on aacu0
aacdu1: 238289MB (488015872 sectors)

CLI > open aac0
Executing: open "aac0"
Command Error: The current AFAAPI.DLL is too old to work with the current
controller software.

Latest Adaptec drivers released at 25 Oct 2006, aaccli says "Copyright

Maybe someone already tried to contact Adaptec?

Andrew N. Below
Zenon N.S.P.

More information about the freebsd-stable mailing list