strange behavior of ioapic on PDSME motherboard (was: LSI 53C1030/mpt(4) problem)

John Baldwin jhb at freebsd.org
Mon Dec 4 09:03:16 PST 2006


On Sunday 03 December 2006 22:55, Hiroki Sato wrote:
> Hiroki Sato <hrs at freebsd.org> wrote
>   in <20061202.201139.35852412.hrs at allbsd.org>:
> 
> hr>  Recently I bought Intel Pentium D 945 (3.45GHz), Supermicro PDSME
> hr>  (Intel E7320), and LSI21320RB (PCI-X SCSI HBA using LSI 53C1030).  I
> hr>  installed 6.2-RC1 to an old PATA HDD and attached it to the
> hr>  motherboard, and it worked fine.  However, I installed 21320RB and
> hr>  made several SCSI HDDs attached, some strange problems occurred.
> 
>  It worked when I turned off ioapic and/or acpi.  When acpi was
>  disabled, mpt seemed to work but em did not work due to the UP/DOWN
>  storm ("vmstat -i" did not display an irq for em0 at that time).
>  When ioapic was disabled, all devices worked with shared irqs.
> 
>  So, this is probably an ioapic's issue, not a mpt's, and PDSME
>  specific I guess.  Sorry for the false alarm.
> 
>  John, are there any big changes of ioapic support between RELENG_6
>  and CURRENT?  I would like your comments to narrow down the cause.
>  The 7.0-CURRENT November snapshot could probe the mpt (as a very slow
>  device, though), and both em and mpt worked with acpi/ioapic enabled.
>  I had a look at the changes in sys/i386/i386, but I am not sure
>  if which is likely (or not)...

There aren't any non-cosmetic changes in the apic code between 6.x and HEAD.

-- 
John Baldwin


More information about the freebsd-stable mailing list