strange behavior of ioapic on PDSME motherboard (was: LSI 53C1030/mpt(4) problem)

Hiroki Sato hrs at
Sun Dec 3 20:05:33 PST 2006

Hiroki Sato <hrs at> wrote
  in <20061202.201139.35852412.hrs at>:

hr>  Recently I bought Intel Pentium D 945 (3.45GHz), Supermicro PDSME
hr>  (Intel E7320), and LSI21320RB (PCI-X SCSI HBA using LSI 53C1030).  I
hr>  installed 6.2-RC1 to an old PATA HDD and attached it to the
hr>  motherboard, and it worked fine.  However, I installed 21320RB and
hr>  made several SCSI HDDs attached, some strange problems occurred.

 It worked when I turned off ioapic and/or acpi.  When acpi was
 disabled, mpt seemed to work but em did not work due to the UP/DOWN
 storm ("vmstat -i" did not display an irq for em0 at that time).
 When ioapic was disabled, all devices worked with shared irqs.

 So, this is probably an ioapic's issue, not a mpt's, and PDSME
 specific I guess.  Sorry for the false alarm.

 John, are there any big changes of ioapic support between RELENG_6
 and CURRENT?  I would like your comments to narrow down the cause.
 The 7.0-CURRENT November snapshot could probe the mpt (as a very slow
 device, though), and both em and mpt worked with acpi/ioapic enabled.
 I had a look at the changes in sys/i386/i386, but I am not sure
 if which is likely (or not)...

Scott Long <scottl at> wrote
  in <4571BE11.4030009 at>:

sc> Hiroki Sato wrote:
sc> >  Any suggestions for what I should do for this problem?  I can send
sc> >  more detail information from "boot -v" and/or dev.mpt.0.debug=5, but
sc> >  not sure which message is important for diagnosing.
sc> >
sc> Just for comparison, could you go back to FreeBSD 6.0 and see if the
sc> problems remain?

 No difference when I tried, but it seems not a mpt problem as I wrote
 above.  Thanks for the suggestion, anyway.

"Matthew Jacob" <lydianconcepts at> wrote
  in <7579f7fb0612022224n473c4f42j3a8f829edfc7afe at>:

ly> >  - 2006 Nov 7-CURRENT snapshot probes the two HDDs case, but the HDDs
ly> >    are recognized as very slow devices such as 6MB/s, and accessing
ly> >    it makes the box freeze, too.
ly> The 6MB/s thing I'm working on now. I have no clue about the other
ly> issues at this time.

 I see.  BTW, I confirmed that mpt worked on the November snapshot
 except the data transfer rate was 6.6MB/s.  Is it worth trying the
 latest current?

| Hiroki SATO
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-stable mailing list