Linuxulator & UDP & PowerWare LanSafe III

Igor Robul igorr at
Thu May 26 02:05:19 PDT 2005


I have recently upgraded (via complete install) both our server from 
FreeBSD 4.10-STABLE to
FreeBSD 5.4-STABLE and I got strange problem.

We are using PowerWare 9125 UPS, and PowerWare does not have FreeBSD 
version of UPS monitoring software. They have
Linux version which worked very good on FreeBSD 4.X.
PowerWare soft has two parts: daemon, which monitors UPS, and client 
(there are  text mode, GUI for X11 and GUI for Windows versions).

They use UDP for communications.
If I try connect to ls3 (daemon) which is running on FreeBSD 5.4-STABLE, 
then I get message about timeout from client part (ls3con).
I see UDP packets from client to server with tcpdump on lo0 interface 
(with local client) or on fxp0 interface with remote client. But server 
start responding after 30-50 seconds. ls3con does not see server 
responses and gives error message about timeout. With command line 
client it IS possible sometime connect to server if I start client after 
error message, and if client uses same local UDP port as before, then it 
gets _previous_ server response. Then they estabilish TCP connection and 
all works OK.

With FreeBSD 4.X there are no any timeouts, server responds fast enought 
for client to see response. To be sure I have tried this with
server in remote office, which I have not upgraded yet.

So, does anybody have same problems? I think, that problem may be in 
LanSafe application, but ...
Also, maybe anybody knows other software which will work with PowerWare 
9125 UPS?
This UPS is not supported by NUT.

More information about the freebsd-stable mailing list