USB keyboard support in 5.4

Wilde, Donald dwilde at
Thu May 19 09:16:00 PDT 2005

I recently cvsup'd to -STABLE a clean 5.4 install, and when I did so, my
USB keyboard (on a Dell GX280) did not work in single-user mode. I had
previously (when working with 5.4-RELEASE as a clean install) created an
/etc/rc.i386 file with the kbdcontrol redirect line in it as specified
in the Handbook, and that worked fine. During the final mergemaster run
in upgrading to -STABLE, the rc.i386 file I'd created was removed as

What worked was to remove 'device atkbd' from the kernel, rebuild, and
reboot, as per the ukbd man page. The only remaining issue is that in
bootup I get a complaint from kbdcontrol that device /dev/ukbd0 is busy.
It's after mounting filesystems and doesn't show up in dmesg. Grepping
/etc, I see that there's an attach/detach sequence in /etc/devd.conf
which includes a kbdcontrol line for /dev/ukbd0. Should I modify this?
My GX280 has no old-style kbd or ps2 mouse ports at all.

Don Wilde

More information about the freebsd-stable mailing list