5.4 install disc1 will not find hard drive

fbsd_user fbsd_user at a1poweruser.com
Sat May 14 12:54:08 PDT 2005

I have seen this problem on the questions list since 5.0 first can out as
development version. Here 5.4 is now stable release and this problem is
still not fixed. I have been using the same pc to test installing stable
versions from miniinst.iso every version since 3.4 without any problems.
Even 5.3-miniinst.iso worked just 2 weeks ago. The 5.4 stable does not have
a miniinst.iso file so this time I used the disc1.iso to burn the install cd
from and when booting from this cd I now get no hard drive found message
from sysinstall (standard install) menu. This sure looks very strange to me
as I can put in the cd burned from the 5.3-miniinst.iso file and the system
installs just fine. Only difference is using disc1 this time. Even though
the md5 CHECKSUM matched I downloaded and reburned disc1.iso again just to
verify it was good.

Power management and APIC have been bios disabled since version FreeBSD 3.4
version so that is not the problem. I tried selecting safe option to boot
and still get same error 'no hard disk found".   My hard drive is an western
digital 310100 on ata0 as master. When using this 5.4 install cd on other
pc/ motherboard/ hard drive combos I get same error.

I think there is something wrong with the build process of the disc1.iso
file. The miniinst.iso must be build using a different canned script that
does not incorporated the bug that is in the disc1 build.   Maybe the .ISO
builds team needs to take a look at this problem.

And to continue on with this thought  why does 5.4 NOT have a miniinst.iso

More information about the freebsd-stable mailing list