Strange SMP problem

Tim Aslat tim at
Mon May 2 23:18:27 PDT 2005

Hi All,

Just had a strange problem with my desktop.

I rebuilt world from sources downloaded a few hours ago, rebooted and
everything worked fine.  Then I noticed that I had HTT turned off,
rebooted, enabled HTT in the bios and booted up again.  The system
seemed to work ok, until I tried loading several apps under X (mozilla,
firefox, dillo, xmms) when they would just freeze.  They couldn't be
killed, even using kill -9, and none of the windows actually loaded onto
the desktop.  The desktop itself (fluxbox) loaded perfectly, as did some
of the dockapps I have installed.

I rebooted again, turned off HTT and lo & behold, everything is working
perfectly again.

I have SMP compiled into the kernel, however I had the machine in
non-HTT mode when I rebuilt world & kernel this morning. Could that have
had something to do with it?

There were no core dumps, or traces I could do, the system just ground
to a halt and had to be hard reset.

bofh.zaphod [11:39am] [~] >uname -a
FreeBSD 5.4-STABLE FreeBSD 5.4-STABLE #19: Tue May
 3 10:19:03 CST 2005    
root at  i386



Tim Aslat <tim at>
Spyderweb Consulting
Phone: +61 8 84193434
Mobile: +61 0401088479

More information about the freebsd-stable mailing list