xffm - xfsamba4 broken in 5-stable?

Torfinn Ingolfsen torfinn.ingolfsen at broadpark.no
Thu Mar 17 14:53:32 PST 2005


Are there any known problems with xfsamba4 (part of xffm, which is part
of the xfce desktop) in FreeBSD 5-stable?

The problem is that I can start xffm (or xfsamba4) and try to access the
SMB Network. xffm says "Lloading...",  the status window shows 
"XFSAMBA> nmblookup -M -- -" and then nothing happens. If I run the
same nmblookup command from the same shell (and the same user) it
completes immediately.

It works on 4-stable, with xfce 4.0.6:
root at kg-htpc# uname -a
FreeBSD kg-htpc.kg4.no 4.9-STABLE FreeBSD 4.9-STABLE #4: Sat Apr  3
16:54:21 CEST 2004     root at kg-htpc.kg4.no:/usr/obj/usr/src/sys/HERMES 

root at kg-htpc# pv | grep xfce4-fm
xfce4-fm-4.0.6_1            =  up-to-date with port

I have tried this on two machines with 5-stable, one is from November
root at kg-work# uname -a
FreeBSD kg-work.kg4.no 5.3-STABLE FreeBSD 5.3-STABLE #1: Sun Nov 14
20:19:11 CET 2004     root at kg-work.kg4.no:/usr/obj/usr/src/sys/SS51G 

and the other from February:
tingo at kg-jobbpc3$ uname -a
FreeBSD kg-jobbpc3.kg4.no 5.3-STABLE FreeBSD 5.3-STABLE #1: Sat Feb  5
20:36:25 CET 2005     root at kg-jobbpc3.kg4.no:/usr/obj/usr/src/sys/T41 

xfce is version 4.2.0:
xfce4-fm-4.2.0              =  up-to-date with port
xfce4-fm-4.2.0_1            =  up-to-date with port

I have read through /usr/ports/UPDATING but coldn't find any hints
there, I have searched Google, and I have checked xffm on Freshports.
Nowhere have I found a hint that will help me fix this.

Any hints appreciated.
Torfinn Ingolfsen,

More information about the freebsd-stable mailing list