Hp dc7100 installs 5.4-rc1 from CD but won't boot from HD

John Hawkes-Reed hirez at libeljournal.com
Thu Apr 14 13:04:55 PDT 2005

At 19:00 14/04/2005, Zsolt =?ISO-8859-2?Q?K=FAti?= wrote:
> > On Mon, 11 Apr 2005, John Hawkes-Reed wrote:
> >
>  > (Which I think covers the problem)
>  >
>  > Boots from CD ok, USB keyboard seems less than reliable, so I'm
>  > using a PS2 item. Running through 'standard' install appears to
>  > write data to the (SATA ICH6 controller) disk, but on reboot it sits
>  > at the F1: FreeBSD prompt beeping every ten seconds.
>  > Is there likely to be anything obvious I've missed? (Or indeed more
>  > useful data I can provide.)
>I had the same problem recently. What I figured out is that in the BIOS
>  you can change automatic geometry detection to another one. Don't
>remember which. Mail me if you can't find it.

I thought I'd been through all the combinations available in the BIOS, but 
I won't be surprised if I missed one. What worked for you?

One thing, probably critical, that I forgot to mention in the excitement, 
is that fdisk complains that the reported geometry is 'wrong' and 
substitutes another C/H/S combination that doesn't use all the disk. 
Neither that, nor the different again combination reported by atacontrol, 
appeared to make much difference. My notes on the relevant values are at 
work, but I'll happily reproduce them if needed.

[ ... ]

Doug White wrote:

>Your system appears to require packet mode, but sysinstall didn't enable
>it.  Two possible fixes:
>1. If you have disc 2: Boot the install CD, go to Fixit, start up fixit
>off CD, then run
>boot0cfg -o packet adX
>where adX is the appropriate disk device.
>2. Reinstall, but use the standard MBR rather than the boot manager. Once
>you get the system booted you can install the boot manager with:
>boot0cfg -B -o packet adX
>where adX is the appropriate disk device.

Aha! Thanks. I think I've got some reading up to do...

In the end I ran out of time, so created a small partition and installed a 
minimal Debian thereon. Grub boots into 5.4 and all's well with the world. 
However, for the sake of completeness and to provide an answer for the next 
poor sod who meets this problem, I'll overwrite Debian and try the above.


More information about the freebsd-stable mailing list