NFS problem?

Hiroki Sato hrs at
Thu May 8 08:02:49 PDT 2003


 I noticed that my 4.8R box seems to have a NFS problem.
 I use a FreeBSD/i386 4.8R box as a NFS server, and 
 a FreeBSD/i386 5-CURRENT (as of today) as the NFS client.

 On the client, /a (on the server) can be mounted successfully
 with -o rw,bg,intr,mntudp options.  However, when a large amount
 of write operations such as "cp -r /home/ncvs /a" are performed
 on the client, the transfer is unexpectedly stalled and
 "nfs server xxx:/a: not responding" is reported.
 A long time (about 10-20 minutes) later, the operations
 are finished.

 During the stall, tcpdump on the server says repeatedly
 the following:

  23:44:43.050494 nfsclient.1731995803 > nfsserver.nfs: 1472 write [|nfs] (frag 33263:1480 at 0+)
  23:44:43.050506 truncated-ip - 2 bytes missing! nfsserver > nfsclient: udp (frag 33263:224 at 1480)

 Did anyone experience this symptom?  I tried NetBSD/sparc64
 as a NFS client, but got the same result.

| Hiroki SATO  <hrs at> / <hrs at>

More information about the freebsd-stable mailing list