Fwd: FreeBSD Sparc 11.0 RC1 Install Problem

Chris syseng at gfsys.co.uk
Thu Sep 8 21:41:26 UTC 2016

On 09/07/16 21:51, Marius Strobl wrote:

> Hi,
> while syscons(4) and vt(4) don't play well together on sparc64 when
> both are compiled into the same kernel (as it's the case for 11.0-RC2
> GENERIC), I can't actually trigger a boot hang with that combo.
> Unfortunately, the information provided above also doesn't make much
> sense; e. g. vt(4) already is the default with 11.0-RC2 GENERIC so
> setting it via loader.conf is redundant and it remains unclear what
> vt(4) is doing, i. e. whether it is driving some hardware (or at
> least trying to).
> How did you obtain the nexus0 line or see that the boot hangs after
> uhub2; are you using LOM or serial console? Is there actually a
> graphics card in that machine? What happens if you use a custom
> built kernel without vt(4)?
> Marius

A bit more info. Rebuilt the kernel today with sc and some other
unneeded stuff commented out. The system hangs using a command
line reboot, so the problem is repeatable. Dropping into ilom and
doing a reset produces the same result, but power off and back on
and the system boots normally.

System hangs after the last line below:

> vent timer "tick" frequency 1504000000 Hz quality 1000
> Timecounters tick every 1.000 msec
> usbus0: 12Mbps Full Speed USB v1.0
> usbus1: 12Mbps Full Speed USB v1.0
> ugen0.1: <AcerLabs> at usbus0
> uhub0: <AcerLabs OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
> ugen1.1: <AcerLabs> at usbus1
> uhub1: <AcerLabs OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
> usbus2: 480Mbps High Speed USB v2.0
> ugen2.1: <AcerLabs> at usbus2
> uhub2: <AcerLabs EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
> (da0:mpt0:0:0:0): UNMAPPED
> da0 at mpt0 bus 0 scbus2 target 0 lun 0
> uhub0: 3 ports with 3 removable, self powered
> da0: <HITACHI H103014SCSUN146G A160> Fixed Direct Access SPC-4 SCSI device
> uhub1: 3 ports with 3 removable, self powered
> da0: Serial Number 000924F5B2JE        PCV5B2JE
> da0: 300.000MB/s transfers
> da0: Command Queueing enabled
> da0: 140009MB (286739329 512 byte sectors)
> SMP: AP CPU #1 Launched!
> cd0 at ata2 bus 0 scbus0 target 0 lun 0
> cd0: Trying to mount root from ufs:/dev/da0a [rw]...
> <MATSHITA DVD-RAM UJ-85JS F100> Removable CD-ROM SCSI device
> cd0: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
> cd0: Attempt to query device size failed: NOT READY, Medium not present
> uhub2: 8 ports with 8 removable, self powered

This is on a V215 machine and would expect the same on a 245, as it uses
the same m/b. Haven't tried others...


More information about the freebsd-sparc64 mailing list