Fwd: cannot edit the sudoers file

Aijaz Baig aijaz.abaig at gmail.com
Sat Apr 5 14:31:52 UTC 2008


In relation to my previous question about not being able to edit the
'sudoers' file, I was finally able to edit the file. Since I still couldn't
find any concrete information about visudo and how to get it, I used emacs
to edit that file instead.

I uncommented the last line which should allow all the users to issue the
'shutdown -h now' command. Still users aren't able to issue that command.
I even tried doing that on an individual basis as in

*user **ALL=/sbin/shutdown -h now**

*Still the *user *isn't able to use shutdown.

Any suggestions are welcome.

Best Regards,

Aijaz Baig.

---------- Forwarded message ----------
From: Aijaz Baig <aijaz.abaig at gmail.com>
Date: Sat, Apr 5, 2008 at 10:35 AM
Subject: cannot edit the sudoers file
To: freebsd-sparc64 at freebsd.org


I am not able to edit the sudoers file even though I do have sudo installed
on the box. Theres been some confusion in my mind regarding what actually
happened when I tried to install sudo.

I did a *make install visudo* in the /usr/ports/securoty/sudo and I could
see a lot of information in the terminal and finally it gave the following
two messages:
" ===>   Compressing manual pages for sudo-
===>   Registering installation for sudo-
      This port has installed the following binaries which execute with
      increased privileges.

      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.

      For more information, and contact details about the security
      status of this software, see the following webpage:
make: don't know how to make visudo. Stop "

Now what is happening is that I can issue the sudo and the sudoedit commands
from the terminal as they are in my path. However I still do not understand
where to fetch the visudo wrapper from? Is it some kind of a scrip which is
to be run from the terminal or what?

AdditionallY I did all this as I wanted to have all my users access to the
'shutdown' command and for that i needed to edit the */usr/local/etc/sudoers
*file and even though I use the following command "sudo emacs
/usr/local/etc/sudoers" I am still not able to edit the file. I also tried
using *sudo chown root: /usr/local/etc/sudoers *but to no avail.

Could someone please help me.

Hope to hear from you soon,

Best Regards,

More information about the freebsd-sparc64 mailing list