NFS install writability on Netra t1 105

Nicholas Riley njriley at
Tue Jan 3 06:37:52 PST 2006

On Tue, Jan 03, 2006 at 02:21:49PM +0100, Gianluca Camporeale wrote:
> could you explain the procedure that you used to boot from
> network and start installation from nfs? I'll tray netboot with
> tftp installation on ultra2 and ultra5 machines but with no
> fortune.

Sure.  At worst you'll get stuck like I am :-)

I installed rarpd (on Linux, since I could not get the OS X version to
do anything beyond printing "got a packet") and edited /etc/ethers as


where the first part is the MAC address of the first ethernet
interface on the Sun, and the second is an IP address I picked.  Newer
Suns can do DHCP, but I think the OpenBoot version on mine is too old.

Then I copied boot/loader from the first FreeBSD install CD to
/tftpboot, made a symlink named with a hex version of the IP address,
and started tftpd (on a different machine from the rarpd server).  If
you're using OS X 10.4 as I was, you can start tftpd with "sudo
launchctl start".  The relevant part of the
(/private)/tftpboot directory looks like:

  lrwxr-xr-x   1 root  wheel       6B Dec 31 14:02 0A0000C8@ -> loader
  -r-xr-xr-x   1 root  wheel     195K Dec 31 14:01 loader*
Next I set up a NFS server.  I first tried directly exporting the
automounted CD image (/Volumes/FreeBSD_Install), but when I tried to
mount that, the mount point was empty; not quite sure what was going
on there.  So instead, I copied the contents to a local disk:

  % nidump exports /
  /Users/Shared/FreeBSD_Install  -ro -mapall=nobody 
(that'd be /etc/exports or /etc/dfs/dfstab on a more normal Unix
system) and I was able to mount it successfully.

Finally, I set up a DHCP server (ISC dhcpd 3) to serve the NFS root
information.  The network already has a DHCP server device which I
couldn't add arbitrary information to - actually, I plan for this Sun
to be the new DHCP server if I ever get it installed!  dhcpd.conf is:

  ddns-update-style none;
  default-lease-time 600;
  max-lease-time 7200;
  log-facility local7;
  subnet netmask {
  host install {
    hardware ethernet 08:00:20:c2:8d:f0;
    always-reply-rfc1048 on;
    option root-path "";
At that point all that remained was typing 'boot net' on the Sun.

  Boot device: /pci at 1f,0/pci at 1,1/network at 1,1  File and args: /platform/sun4u/kernel/unix
  34e00 Consoles: Open Firmware console  
  FreeBSD/sparc64 bootstrap loader, Revision 1.0
  (root at, Wed Nov  2 09:45:36 UTC 2005)
  bootpath="/pci at 1f,0/pci at 1,1/network at 1,1"
  boot: ethernet address: 08:00:20:c2:8d:f0
  net_open: server addr:
  net_open: server path: /Users/Shared/FreeBSD_Install

There'll be a short delay, then "Loading /boot/defaults/loader.conf",
then a longer delay before the FreeBSD kernel starts booting.

>From looking at boot/loader.conf on the CD, it looks like I'm supposed
to get a MFS root, but instead I get a (read-only) NFS root.  During
boot I do see this line:

  md0: Preloaded image </boot/mfsroot> 4194304 bytes at 0xc056435

and I was able to mount /dev/md0 after startup, but I can't figure out
how to get it to be used as a root device.

Nicholas Riley <njriley at> | <>

More information about the freebsd-sparc64 mailing list