6.0-BETA5 and Ultra 1 !?

Gheorghe Ardelean ardelean at ww.uni-erlangen.de
Mon Oct 17 17:20:59 PDT 2005


As I have an unsupported Plain Ultra 1 I was trying to play with it and
6.0-BETA5. I have just installed the 6.0-BETA5 on a Diff SCSI drive in an
Ultra 5 and then moved the drive to the Ultra 1 with additional SBUS
Diff SCSI card from Qlogic and a SUN FAS366 SBUS Card (which I
planned to use for network connection).

To my surprise it booted ok (last time I have tried with 5.x it gave me
no console ) and *recognized* the onboard SCSI controller (console on
serial port). After that I have mounted the internal CDROM and I was able
to copy data from the installation CD to a directory on the Diff SCSI HDD.

So it really seems that the onboard SCSI is supported (at least to some
extent) on a Plain Ultra 1!

I have made a dump|restore of the boot disk to the internal one.
Everything went ok. I have tried now to boot from the internal one and I

Rebooting with command: boot
Boot device: disk:a  File and args:

>> FreeBSD/sparc64 boot block
   Boot path:   /sbus at 1f,0/espdma at e,8400000/esp at e,8800000/sd at 0,0:a
   Boot loader: /boot/loader
Consoles: Open Firmware console

FreeBSD/sparc64 bootstrap loader, Revision 1.0
(root at u60.samsco.home, Mon Sep 19 02:48:26 UTC 2005)
bootpath="/sbus at 1f,0/espdma at e,8400000/esp at e,8800000/sd at 0,0:a"
Fast Data Access MMU Miss

So I am not able to boot from it but I can use it if I boot from the other
disc (Diff SCSI one). What could this be?


Gheorghe Ardelean.

Here is the dmesg:

Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 6.0-BETA4 #0: Tue Sep 20 06:20:12 UTC 2005   << The BETA5 ISO pretends to be BETA4
    root at u60.samsco.home:/usr/obj/usr/src/sys/GENERIC
Timecounter "tick" frequency 142986531 Hz quality 1000
real memory  = 234881024 (224 MB)
avail memory = 209690624 (199 MB)
cpu0: Sun Microsystems UltraSparc-I Processor (142.99 MHz CPU)
nexus0: <Open Firmware Nexus device>
sbus0: <U2S UPA-SBus bridge> on nexus0
sbus0: clock 25.000 MHz
sbus dvma: DVMA map: 0xfc000000 to 0xffffffff
sbus0: [FAST]
sbus0: [FAST]
initializing counter-timer
Timecounter "counter-timer" frequency 1000000 Hz quality 100
auxio0: <Sun Auxiliary I/O> mem 0x1900000 on sbus0
sbus0: <SUNW,CS4231> mem 0xc000000-0xc0001ff irq 2020 type unknown (no driver at tached)
sbus0: <flashprom> mem 0-0x7ffff,0x1380000-0x13fffff type unknown (no driver att ached)
sbus0: <SUNW,fdtwo> mem 0x1400000-0x1400007 irq 2025 type block (no driver attached)
eeprom0: <EEPROM/clock> mem 0x1200000-0x1201fff on sbus0
eeprom0: model mk48t59
eeprom0: hostid 8085fe27
puc0: <Zilog Z8530 dual channel SCC> mem 0x1100000-0x1100003 irq 2024 on sbus0
uart0: <z8530, channel A> on puc0
uart0: console (9600,n,8,1)
uart1: <z8530, channel B> on puc0
puc1: <Zilog Z8530 dual channel SCC> mem 0x1000000-0x1000003 irq 2024 on sbus0
uart2: <z8530, channel A> on puc1
uart2: keyboard (1200,n,8,1)
uart2: keyboard not present
uart3: <z8530, channel B> on puc1
sbus0: <sc> mem 0x1300000-0x1300007 type unknown (no driver attached)
sbus0: <SUNW,pll> mem 0x1304000-0x1304002 type unknown (no driver attached)
dma0: <espdma> mem 0x8400000-0x840000f on sbus0
dma0: DMA rev. 2
esp0: <Sun ESP SCSI/Sun FAS Fast-SCSI> mem 0x8800000-0x880003f irq 2016 on dma0
esp0: FAS100A, 40MHz, SCSI ID 7
dma1: <ledma> mem 0x8400010-0x840002f on sbus0
dma1: DMA rev. 2
dma1: <le> mem 0x8c00000-0x8c00003 irq 2017 type network (no driver attached)
sbus0: <SUNW,bpp> mem 0xc800000-0xc80001b irq 2018 type unknown (no driver attached)
hme0: <Sun HME 10/100 Ethernet> mem 0x8c00000-0x8c00107,0x8c02000-0x8c03fff,0x8c04000-0x8c05fff,
      0x8c06000-0x8c07fff,0x8c07000-0x8c0701f irq 1988 on sbus0
miibus0: <MII bus> on hme0
nsphy0: <DP83840 10/100 media interface> on miibus0
nsphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
hme0: Ethernet address: 08:00:20:85:fe:27
esp1: <Sun FAS366 Fast-Wide SCSI> mem 0x8800000-0x880000f,0x8810000-0x881003f irq 1987 on sbus0
esp1: FAS366/HME, 40MHz, SCSI ID 7
isp0 mem 0x10000-0x1044f irq 1995 on sbus0
sbus0: <cgsix> mem 0-0xffffff irq 2005 type display (no driver attached)
nexus0: <syscons>, type (unknown) (no driver attached)
Timecounters tick every 1.000 msec
Waiting 5 seconds for SCSI devices to settle
da1 at isp0 bus 0 target 0 lun 0
da1: <SEAGATE ST32550W HP09> Fixed Direct Access SCSI-2 device
da1: 20.000MB/s transfers (10.000MHz, offset 12, 16bit), Tagged Queueing Enabled
da1: 2033MB (4165272 512 byte sectors: 255H 63S/T 259C)
cd0 at esp0 bus 0 target 6 lun 0
cd0: <TOSHIBA XM-5401TASUN4XCD 1036> Removable CD-ROM SCSI-2 device
cd0: 4.032MB/s transfers (4.032MHz, offset 15)
cd0: cd present [1074528 x 512 byte records]
da0 at esp0 bus 0 target 0 lun 0
da0: <IBM DORS32160SUN2.1G WA7A> Fixed Direct Access SCSI-2 device
da0: 10.000MB/s transfers (10.000MHz, offset 15), Tagged Queueing Enabled
da0: 2063MB (4226725 512 byte sectors: 255H 63S/T 263C)
Trying to mount root from ufs:/dev/da1a

More information about the freebsd-sparc64 mailing list