cant do anything to process via cron on 5.2.1-RC

Ivo Mencke imencke at
Mon Oct 11 02:35:44 PDT 2004

Hello list members,

This should probably go to freebsd-users, but all i run here is freebsd
on sparc64 so i thought i'd try this first. I am running the sparc64
port for some time now on sun E220's, and for the first time i have
tried to use cron to restart bind daily.

All normal commands like "touch /testfile" work fine but anything i try
on the named process refuses to work, like to kill it, or just to run
"/etc/rc.d/named restart". These commands work fine if i run them from
the cli.

Could this be because it is running chroot'ed into /etc/namedb ? any
help greatly appreciated, 



*note the 2 output lines from "ps" are wrapped

NS1# crontab -l
18       10       *       *       *       pkill named

NS1# date
Mon Oct 11 10:19:18 IST 2004
NS1# ps waux | grep -i named | grep -v grep
root    245  0.0  0.4  3672 1072  ??  Ss    3Sep04   0:49.14
/usr/sbin/syslogd -l /etc/namedb/dev/log
bind  62915  0.5  4.3 15624 10896  ??  Ss    9:48AM   0:41.88 named -u
bind -c /etc/named.conf -t /etc/namedb
NS1# tail -3 /var/log/cron
Oct 11 10:18:00 NS1 /usr/sbin/cron[63962]: (root) RELOAD (tabs/root)
Oct 11 10:18:00 NS1 /usr/sbin/cron[64126]: (root) CMD (pkill named)
Oct 11 10:19:16 NS1 crontab[64209]: (root) LIST (root)

More information about the freebsd-sparc64 mailing list