don't know how to make dummy.c

Rik Wade rik at
Wed Jul 14 06:36:32 PDT 2004

Ken Smith wrote:
> The times I've seen something weird like this were due to the system's
> clock being something totally unreasonable.  Check to see what the
> current time is on the system and if it's wrong manually set it to
> something realistic and try the build again.
> If that's not it let us know.

The clock was slightly out (in the future by a couple of minutes) so I 
reset it and tried again. Same error unfortunately. However, in the 
process, I noticed that the timestamp for all the files on my system 
appears to be "Jan 1 1970". If I touch a new file, it is created with 
the date "Jan 1 1970".

If this is not a normal state of affairs (and I'm guessing that it isn't 
;-) ) then it seems likely that I've made a mistake somewhere along the 
upgrade process. In this case, I will regress and start again with an 
old kernel.

bash-2.05b# date
Wed Jul 14 14:34:12 BST 2004
bash-2.05b# pwd
bash-2.05b# touch a.test
bash-2.05b# ls -l
total 14
-rw-r--r--  1 root  wheel  1567 Jan  1  1970 Makefile
-rw-r--r--  1 root  wheel     0 Jan  1  1970 a.test
-rw-r--r--  1 root  wheel   119 Jan  1  1970 dummy.c
-rw-r--r--  1 root  wheel  1750 Jan  1  1970 endian.h
-rw-r--r--  1 root  wheel   340 Jan  1  1970 langinfo.h
drwxr-xr-x  2 root  wheel   512 Jan  1  1970 mk
-rw-r--r--  1 root  wheel   592 Jan  1  1970 progname.c
-rw-r--r--  1 root  wheel   131 Jan  1  1970 regex.h


More information about the freebsd-sparc64 mailing list