getty on the serial console

Peter Larkowski peter at
Tue Sep 30 17:25:37 PDT 2003

Sorry for the unnecessary post.  I figured it out.  I need to run the 
getty on /dev/console and not /dev/ttya and then it works, even though 
/dev/ttya is the serial port in question.

I'm still not sure why I didn't get messages past mounting root when I 
was running 5.1-RELEASE, but -CURRENT seems to have fixed a few 
problems on the Ultra-AXe.


On Tuesday, September 30, 2003, at 07:58 PM, Peter Larkowski wrote:

> Hi again,
> I never managed to get the 5.1 cd booted successfully on my ultra AXe, 
> but I did do a buildworld to RELENG_5_1 from 9-28.  After the upgrade, 
> the machine boots to the end of the kernel messages *mounting root 
> from /dev/da0a", and then I got "PID ?? (fsck_ufs) exited on signal 8" 
> twice, and then nothing more on the serial console.  THe machine 
> continued booting normally (I assume anyway, as I could log in via 
> ssh).
> After a subsequent buildworld, buildkernel, install everything, 
> mergemaster, etc, to CURRENT from 9-29, I get all the startup messages 
> (ssh, sendmail, etc) until the login prompt.  The last thing printed 
> is the date.  Again, everything else is fine.  getty is running.
> Any ideas why I don't have login prompt on the serial console?
> -p
> On Saturday, September 27, 2003, at 06:52 PM, Peter Larkowski wrote:
>> Hi again:
>> Just as a follow up, on my Ultra AXe, it doesn't make any difference 
>> if this is an IDE cdrom or a SCSI cdrom.  Also, dd'ing the boot.flp 
>> to the front of a hard drive produces the same results:  The system 
>> hangs on 5.1-RELEASE with no useful messages when "Mounting root from 
>> UFS:/dev/md0"  Again, the 5.0-RELEASE cd works.  Suggestions?
>> Thanks in advance.
>> -p
>> On Thursday, September 25, 2003, at 10:57 AM, peter at 
>> wrote:
>>> Hi everyone.
>>> I have 5.0-RELEASE installed on my sparcengine ultra AXe.  I haven't
>>> messed with it in months and was going to try and upgrade it to 
>>> something
>>> more recent.  First I tried a make buildworld with CURRENT sources 
>>> from a
>>> couple days ago (9-23 or 9-22, I don't remember), but I got some 
>>> errors.
>>> I could have missed something in UPDATING, I don't really know.
>>> In any case, I decided to reinstall with UFS2 and just in general 
>>> get a
>>> fresh start since it's been so long since I messed with this 
>>> machine.  The
>>> 5.1 cd gets to mounting root from /dev/md0 and hangs.  There was a 
>>> thread
>>> about this same problem on an ultra 10 some months ago, but it was 
>>> never
>>> resolved afaik and turned into an argument about blocking entire dsl
>>> subnets to stop spam :)  Anyway, does anyone have any suggestions for
>>> getting 5.1 or -current on my sparc?  I'm using an LSI logic SCSI 
>>> card and
>>> the cdrom is a an external plextor that does boot the 5.0 disc just 
>>> fine
>>> (I checked again last night).
>>> Thanks,
>>> -p
>>> _______________________________________________
>>> freebsd-sparc64 at mailing list
>>> To unsubscribe, send any mail to 
>>> "freebsd-sparc64-unsubscribe at"
>> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> Peter Larkowski
>> mailto: peter at
>> _______________________________________________
>> freebsd-sparc64 at mailing list
>> To unsubscribe, send any mail to 
>> "freebsd-sparc64-unsubscribe at"
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> Peter Larkowski
> mailto: peter at
> "To announce that there must be no criticism of the President, or that 
> we are to stand by the President, right or wrong, is not only 
> unpatriotic and servile, but is morally treasonable to the American 
> public."
> --Theodore Roosevelt, Republican, 26th President of the United States
> _______________________________________________
> freebsd-sparc64 at mailing list
> To unsubscribe, send any mail to 
> "freebsd-sparc64-unsubscribe at"
Peter Larkowski
mailto: peter at

More information about the freebsd-sparc64 mailing list