Booting from ISP on U2

Tomi Vainio - Sun Finland Tomi.Vainio at Sun.COM
Wed Sep 24 12:12:17 PDT 2003

jtregunna at writes:
 > I'm trying to get FreeBSD to boot from a disk that is connected to the
 > onboard fas scsi controller, but through the QLogic ISP1000 SBus card
 > in this system. Is this even possible? I've seen other posts about this
 > but have not been able to find out exactly how to do it. I've tried
 > booting using: boot /sbus at 1f,0/QLGC,isp at 3,10000/sd at 0,0 and also tried
 > with a :a appended to the end of that. I get Can't open boot device
 > each time I try and boot. There is an installed system on there, it
 > is not yet FreeBSD, but I want to make sure I can boot from the ISP
 > before installing. I'd like to get to installing today.
 > Any help would be appreciated.
I've done this at least once using Ultra1E about year ago.  I even
found boot log from that.


ok boot cdrom
Resetting ... 

Sun Ultra 1 UPA/SBus (UltraSPARC 200MHz), No Keyboard
OpenBoot 3.11, 128 MB memory installed, Serial #10350439.
Ethernet address 8:0:20:9d:ef:67, Host ID: 809def67.

Initializing Memory \
Rebooting with command: boot cdrom
Boot device: /sbus/SUNW,fas at e,8800000/sd at 6,0:f  File and args: 
>> FreeBSD/sparc64 boot block
   Boot path:   /sbus at 1f,0/SUNW,fas at e,8800000/sd at 6,0:f
   Boot loader: /boot/loader
Console: OpenFirmware console
Boot path set to /sbus at 1f,0/SUNW,fas at e,8800000/sd at 6,0:a

FreeBSD/sparc64 bootstrap loader, Revision 1.0
(scottl at, Sun Dec 22 09:20:57 MST 2002)
bootpath="/sbus at 1f,0/SUNW,fas at e,8800000/sd at 6,0:a"
|Loading /boot/defaults/loader.conf 
/boot/kernel/kernel data=0x313208+0xe8c48 /syms=[0x8+0x498c0-\|+0x8+0x38d77/]
Hit [Enter] to boot immediately, or any other key for command prompt.
nothing to autoload yet.
-\|/jumping to kernel entry at 0xc0038000.
stray vector interrupt 2033
Copyright (c) 1992-2002 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.0-RC2 #0: Sun Dec 29 00:27:38 GMT 2002
    root at
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0882000.
Preloaded mfs_root "/boot/mfsroot" at 0xc0882190.
Timecounter "tick"  frequency 199996218 Hz
cpu0: Sun Microsystems UltraSparc-I Processor (200.00 MHz CPU)
Model: SUNW,Ultra-1
Initializing GEOMetry subsystem
md0: Preloaded image </boot/mfsroot> 4194304 bytes at 0xc047e498
nexus0: <OpenFirmware Nexus device>
sbus0: clock 25.000 MHz
DVMA map: 0xff800000 to 0xffffffff
initialializing counter-timer
Timecounter "counter-timer"  frequency 1000000 Hz
sbus0: <U2S UPA-SBus bridge> on nexus0
sbus0: <SUNW,CS4231>, type (unknown) (no driver attached)
sbus0: <auxio>, type (unknown) (no driver attached)
sbus0: <flashprom>, type (unknown) (no driver attached)
sbus0: <SUNW,fdtwo>, type block (no driver attached)
eeprom0: <SBus EEPROM/clock> mem 0x1200000-0x1201fff on sbus0
eeprom0: model mk48t59
eeprom0: hostid 809def67
sbus0: <zs>, type serial (no driver attached)
sbus0: <zs>, type serial (no driver attached)
sbus0: <sc>, type (unknown) (no driver attached)
sbus0: <SUNW,pll>, type (unknown) (no driver attached)
sbus0: <SUNW,fas>, type scsi (no driver attached)
hme0: <Sun HME 10/100 Ethernet> mem 0x8c07000-0x8c0701f,0x8c06000-0x8c07fff,0x8c04000-0x8c05fff,0x8c02000-0x8c03fff,0x8c00000-0x8c00107 irq 2017 on sbus0
hme0: Ethernet address: 08:00:20:9d:ef:67
miibus0: <MII bus> on hme0
nsphy0: <DP83840 10/100 media interface> on miibus0
nsphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
sbus0: <SUNW,bpp>, type (unknown) (no driver attached)
isp0 mem 0x10000-0x1044f irq 1987 on sbus0
sbus0: <SUNW,socal>, type socal (no driver attached)
nexus0: <SUNW,ffb>, type display (no driver attached)
Timecounters tick every 10.000 msec
Waiting 15 seconds for SCSI devices to settle
da0 at isp0 bus 0 target 2 lun 0
da0: <SEAGATE ST32550W SUN2.1G 0418> Fixed Direct Access SCSI-2 device 
da0: 20.000MB/s transfers (10.000MHz, offset 12, 16bit), Tagged Queueing Enabled
da0: 2048MB (4194995 512 byte sectors: 255H 63S/T 261C)
Mounting root from ufs:/dev/md0
Invalid time in real time clock.
Check and reset the date immediately!
/stand/sysinstall running as init on serial console

These are the predefined terminal types available to
sysinstall when running stand-alone.  Please choose the
closest match for your particular terminal.

1 ...................... Standard ANSI terminal.
2 ...................... VT100 or compatible terminal.
3 ...................... FreeBSD system console (color).
4 ...................... FreeBSD system console (monochrome).

5 ...................... xterm terminal emulator.

Your choice: (1-5) 2

Waiting (max 60 seconds) for system process `bufdaemon' to stop...stopped
Waiting (max 60 seconds) for system process `syncer' to stop...stopped

syncing disks, buffers remaining... 8 8 
Uptime: 2m57s
Program terminated

More information about the freebsd-sparc64 mailing list