Problems booting 4.8R PicoBSD

Chuck T. freebsdfan at
Wed Jul 16 05:39:28 PDT 2003

Everything is from 4.8R.  My primary interest at this point is in 
reproducing the kernel panic I ran into with 4.4R if possible...  Back then 
I was able to PXE boot with the default pxeboot that used both tftp and nfs 
to load.  When I rebuilt pxeboot to use tftp only is when I got a 
reproduceable kernel panic.  I'm trying to determine if the same problem 
exists with 4.8R (I suspect it does).

I'm going to rebuild my kernel with the kernel debugger and poke around and 
see what I can learn.

>From: Bob Bishop <rb at>
>To: "Chuck T." <freebsdfan at>, freebsd-small at
>Subject: Re: Problems booting 4.8R PicoBSD
>Date: Wed, 16 Jul 2003 10:16:12 +0100
>At 18:06 15/7/03, Chuck T. wrote:
>>When I tried that the kernel stopped trying to download /pxeroot/etc/fstab 
>>but it still hung.  I also verified that I do have /dev/md0* device nodes.
>>The way I read the md driver code vfs.root.mountfrom should be set by by 
>>the md driver during initialization.  In my case that doesn't appear to be 
>>happening in my case since my debug printfs were never printed.
>>My 4.6R based project didn't have /dev/md0* devices, but it didn't seem to 
>Another thought: what vintage pxeboot are you using? You might try an 
>older/newer one.
>Bob Bishop		    +44 (0)118 977 4017
>rb at		fax +44 (0)118 989 4254

Help STOP SPAM with the new MSN 8 and get 2 months FREE*

More information about the freebsd-small mailing list