Xorg/Lenovo/drm revisited

Doug Denault doug at safeport.com
Thu Mar 25 16:55:52 UTC 2021

I recently tried to update my Ideapad to 12.2 turning it into a 
paperweight. 13.0 solved that. So I upgraded two Dell towers and an old HP 
laptop to 12.2 all working [almost] without a hitch.

None of these systems recognize double-click as paste in xterm or on the 
xfce desktop. The latter is almost irrelevant as that is supposed to list 
all windows on all desktops (I have 8). Having to drop the mouse and do 
shift-insert is annoying but almost a "who cares".

My question involves trying to fix that. After many attempts I did a `Xorg 
-configure`, lifted the mouse device section and added `Option 
"Emulate3Buttons" "true"` putting that in /usr/local/etc/X11/xorg.conf.d. 
This resulted in the hardware not recognizing the mouse or keyboard. 
Neither deleting the xorg.conf.d entry or changing rc.conf to specify ums0 

startx started X with no mouse or keyboard. The only error I could find in 
message was /dev/psm0 could not be opened. Reinstalling was the only thing 
(I could find) that worked. The system uses ums0.

xinput: System mouse   id=7  [slave pointer  (2)]
ps : /usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.

  [474.691] (**) Option "config_info" "udev:/dev/input/event1"
  [474.691] (II) XINPUT: Adding extended input device "System mouse" (type: MOUSE, id 7)
  [474.691] (**) Option "AccelerationScheme" "none"

Can't open psm0 is written to the console during boot but not logged. All 
of this for two questions:

1) what change from the xorg.conf.d entry could stop the system from
    working after it was removed?
2) does double-click work for most, or is my result the current norm?

Douglas Denault
doug at safeport.com
Voice: 301-217-9220
   Fax: 301-217-9277

More information about the freebsd-questions mailing list