Incorrect permissions on contents of /etc/rc.d leads to being unable to boot

Montgomery-Smith, Stephen stephen at
Tue Feb 2 19:01:57 UTC 2021

First, sorry if this is HTML.  For now I am forced to use Outlook by changes that my employer has made to our mailsystem.

Next, I'm not quite sure where to post this cautionary tail.  But I do think this information may be useful for people working on the tool etcupdate.

I built stable/12 from git for the first time.  mergemaster didn't work because all the header files that start with # $FreeBSD$ had lost their subversion revision numbers.  Then I saw on a mailing list that we are supposed to use etcupdate now.  For whatever reason, I had to use "etcupdate resolve" and it insisted that it resolve every file.

Then I rebooted, and nothing worked.  The internet connection didn't come up, and the file system was mounted read only.  After much detective work, I realized that none of the files in /etc/rc.d were executable.  I used chmod to set them all executable, and then it worked!!!!

So maybe the writers of etcupdate and mergemaster need to make sure that file permissions are set correctly.

Thanks, Stephen

More information about the freebsd-questions mailing list