Booting EFI system without EFI loader

Daniel Stevenson daniel at
Mon Sep 7 17:21:31 UTC 2020

On Sun, Sep 06, 2020 at 06:47:14PM -0700, Kevin Oberman wrote:
> I know it's possible, because I did it once by accident. Now I need to do
> it again.
> I had completed the installation and tried to boot the new system. It
> worked when I tried to boot the USB stick, but something failed with the
> message that no valid system was found and prompted for the bot drive. I
> entered ufs:disk0p6: and the newly installed system came up! I then updated
> to current and built the world and kernel and installed the kernel. Now I
> need to reboot.
> I can't figure out how to get the loader to ask for the boot disk
> (partition). I tried installing the loader into the efi partition as per
> the handbook, but my system was too smart. It didn't like the new
> bootx86.efi file and "fixed" it! ARG!
> Any clue as to how to force my system to boot and NOT "AUTOREPAIR" itself?
> I want to install rEFInd using Niclas Z's instructions as soon as can.
> I seem to be asking for help a lot, but I have not had to deal with this
> stuff since going to EFI. FWIW, the system is a Lenovo L15 (Intel).

You should be able to set the default boot loader from your BIOS,
probably from the "Boot" tab or similar.

Daniel Stevenson

More information about the freebsd-questions mailing list