Booting EFI system without EFI loader

Kevin Oberman rkoberman at gmail.com
Mon Sep 7 01:47:34 UTC 2020


I know it's possible, because I did it once by accident. Now I need to do
it again.
I had completed the installation and tried to boot the new system. It
worked when I tried to boot the USB stick, but something failed with the
message that no valid system was found and prompted for the bot drive. I
entered ufs:disk0p6: and the newly installed system came up! I then updated
to current and built the world and kernel and installed the kernel. Now I
need to reboot.

I can't figure out how to get the loader to ask for the boot disk
(partition). I tried installing the loader into the efi partition as per
the handbook, but my system was too smart. It didn't like the new
bootx86.efi file and "fixed" it! ARG!

Any clue as to how to force my system to boot and NOT "AUTOREPAIR" itself?
I want to install rEFInd using Niclas Z's instructions as soon as can.

I seem to be asking for help a lot, but I have not had to deal with this
stuff since going to EFI. FWIW, the system is a Lenovo L15 (Intel).
--
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: rkoberman at gmail.com
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683


More information about the freebsd-questions mailing list