installed FreeBSD from mfsbsd, but cannot update

Antonio Olivares olivares14031 at
Fri Sep 4 15:36:36 UTC 2020

Dear kind FreeBSD users,

I have installed freebsd 12.1-RELEASE from mfsbsd with ZFS and I
configured SWAP like I wanted to 4GB of SWAP or 2G is not enough.  I
have experience many crashes.  I try to run
# freebsd-update fetch
and it fails
I run
# freebsd-update fetch install
and it also fails.  IT says, if unsupported, FreeBSD must be upgraded by source.
I do not have a working copy of pkg and partitioned using GPT with zfs
and disklayout looks like

ada0     149 GB  GPT
    ada0p1  236 KB freebsd-boot
    ada0p2  16 GB   freebsd-swap
    ada0p3   133 GB freebsd-zfs

I did not run bsdinstall because I just ran example command because I
wanted a 16GB swap partition, and I try to run it and it will modify
everything.  How do I do it so I can run FreeBSD on it and it would

I get error when I run bsdinstall

No root  partition was found.  The root FreeBSD partion must have a
mountpoint of '/'.
< OK >

I did not want to use DVD to install.  I wanted to do it quicker and
with a swap file of 16 GB, the default autozfs and/or auto ufs
defaults do not work like I would for them to.  When building programs
with ports the programs like rust run out of memory.

Thank you for suggestions and advice.  I want to take different
approach.  Chromium is crashing randomly and tabs keep crashing.  I
want to try something different.


More information about the freebsd-questions mailing list