Keyboard and mouse not working after X update

Polytropon freebsd at
Sun May 31 21:17:36 UTC 2020

On Sun, 31 May 2020 22:21:49 +0200, Tomasz CEDRO wrote:
> Hey Poly :-) There were big changes recently in Xorg and video and
> input drivers handling in FreeBSD.. those changes mostly come from and
> are enforced by a Linux world and the hardware vendors.. not really
> much to be done about it rather than adapt (and the upstream
> development). I also experienced those problems with video and I also
> get the impression that input is a bit worse than before.. but it
> works now.. and if you search the history there are people with
> similar problems and solutions :-)

Here is what at the moment (!) works at least for me:

I first verified the system has installed


and it is not running HAL or DBus. I then tried ~/.xinitrc
with the addition of

	setxkbmap -rules evdev -layout de

and removing /usr/local/etc/X11/xorg.conf.d/keyboard-de.conf.

_That_ probably was the correct thing to do, at least here.

Now keyboard language has to be set on a per-user basis, as
it seems... terrible...

Let's see what stops working with the next update, and what
five new ways of fixing it temporarily will emerge. ;-)

The "xinput" command shows both mouse and keyboard correctly,
even though it uses ugly "graphics characters" where something
more ASCII would have been sufficient. Yes, nobody pipes program
outputs anywhere today, people just want colorful screenshots.
I have no idea what to say...

> Another upcoming solution for the Xorg issues may be Wayland on
> FreeBSD instead of Xorg. There also was quite a large mailing thread
> for that. You may take a look at Enlightenment as the Xorg but also
> Wayland enabled WM :-)

That would be no problem for me; hopefully other applications
intended for use with X will soon be ported to work with Wayland.
The current situation is definitely not in line with the decades
of "it just works" experienced on FreeBSD... :-/


It seems that there's still something wrong with the video driver
that X has loaded. It's probably still VESA... while "xvinfo"

	Adaptor #0: "GLAMOR Textured Video"

and "glxinfo" states

	AMD PALM (DRM 2.29.0 / 12.1-RELEASE-p5, LLVM 8.0.1) (0x9802)

I can get only 60 fps in "glxgears" (5600 on my old home PC from 2007).
The user is a member of the "video" group.

Sadly /var/log/Xorg.0.log is far from usable to easily determine
which graphics driver has been loaded;

[   996.700] (II) LoadModule: "ati"
[   996.701] (WW) Warning, couldn't open module ati
[   996.702] (EE) Failed to load module "ati" (module does not exist, 0)

As I mentioned, installing the matching package leads to a black

All that can't be normal... too many moving parts...

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list