Microsoft Teams for Linux

Maciej Suszko maciej at
Thu May 7 22:15:27 UTC 2020

On 5/7/20 2:24 PM, Jerry wrote:
> On Thu, 7 May 2020 14:43:46 +0300, Alexandr Krivulya commented:
>> 06.05.20 10:09, Maciej Suszko пишет:
>>> Just adding freebsd-questions list - anyone here who tried to run or
>>> use Microsoft Teams web/app ?
>>> On 5/5/20 2:52 PM, Maciej Suszko wrote:  
>>>> Hi,
>>>> I'm wondering if anyone tried to use Microsoft Temas either web
>>>> version or desktop app... Web version does work but making
>>>> audio/video call isn't officialy suppported, so you need to spoof
>>>> user-agent to make it partially working - but from time to time MS
>>>> change something and it just stop working. In the past weeks I was
>>>> able to make audio calls, now it's not possible (neither Firefox
>>>> nor Chrome)
>>>> I tested my webcam and mic on and
>>>> it's all working, so problematic is the web application from MS.
>>>> Desktop application - here are two options, one for Linux, one for
>>>> Windows. I tried to run the Linux version using linuxulator,
>>>> brandelf-ing all the binaries but with no success...
>>>> #v+
>>>> tlhscd at arsenic:/tmp/teams/share/teams $ ./teams
>>>> Trace/BPT trap (core dumped)
>>>> #v-
>>>> How do you think - are there any chances to make the desktop app
>>>> working in out FreeBSD desktops?--  
>> Yesterday I tried to call my colleague via Microsoft Teams web-app 
>> (latest Firefox on CURRENT, spoofed User-Agent). Yes, there is no
>> audio and video at all in both directions.
>> If I run desktop version with linux strace and it crashes. I think it 
>> because of unimplemented cgroups calls. Both Microsoft Teams and Skype 
>> are Electron applications, that tries to run chromium in isolated 
>> environment.
>  <Truncated by me>
> There is information on
> <> that
> should assist you. It clearly states that "FIREFOX" is NOT SUPPORTED.
> "Spoofing" a user agent is a waste of time. "You cannot make a silk
> purse out of a sow's ear." Now, Google Chrome, the latest version plus
> two previous versions are FULLY SUPPORTED. Install that and then see
> what happens.

One thing is written on the page, the other is real... I use current
www/chromium and I can't confirm that

tlhscd at arsenic:~ $ chrome --version
Chromium 81.0.4044.129

Someone can tell chromium != Chrome - that's true, but as far as I know,
there is no official Google Chrome for FreeBSD.

> By the way, I made a suggestion on the TEAMS page that FreeBSD should
> be supported since they support Linux. I have already received a couple
> of "Thumbs UP" responses.

Thanks, but I'm realistic - that's similar situation to Widevine - there
are still no binaries for FreeBSD-based browsers... watching Netflix on
FreeBSD - only on virtualbox or bhyve machine.

regards, Maciej Suszko.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list