SSD woes - boot

David Christensen dpchrist at
Wed May 6 16:43:20 UTC 2020

On 2020-05-06 02:56, Christoph Kukulies wrote:
> Since yesterday, when I ran smartcontrol against my drives - don’t know whether it has to do with that but I’m mentioning it just FWIW -
> my Kingston 240 GB SSD suddenly was no longer visible in the ASRock MB’2 BIOS. (ASRock939A790GMH).
> Strange, isn’t it, that a power fail or unclean shutdown/dismount can cause the drive being no longer visible to the BIOS.
> To test whether it was still alive,  I took it out of the system, put it into an ICY box and connected it to a FreeBSD (11) VM I have running under Parallels on my MacbookPro.
> It got recognized on the USB bus and after I ran an fsck against it and put it back into the BIOS, it was recognized again.
> So far so good. But now, due to some misordering in the hard disk numbering scheme in the BIOS I can’t aim at the right partition to boot.
> With the old F1/F5 bootload of FreeBSD it always boots the wrong partition .
> Is there a better bootloader available which offers me a larger choice, that eventually finds all bootable partitions on all disks in the system?

You a whipping a dead horse:


More information about the freebsd-questions mailing list