Mozilla Crasher

Graham Bentley admin at
Mon Jun 29 17:08:15 UTC 2020

Thanks for the replies on this. I ruled out fs corruption and tried
starting Firefox from a term in safe mode. 

Even the safe mode dialogue at start up would cause a seg fault.
It would take out Xorg too and dump me back at cli.

Anyway I am a step close because I discovered that if I run xorg
without the Intel driver (i915kms) my screen is messed up but
Firefox runs fine!

On the working install /boot/modules is populated with lots of
various drivers. On the non working one, it's empty! 

I have no recollection at all of building any modules and I'm unsure
how they got there (but then I have no memory of a lot of things!)

Maybe they where brought in when installing another package?

On the working setup I am running from rc.conf

$ ls -l /boot/modules/i915kms.ko
-r-xr-xr-x  1 root  wheel  2112672 May 15 03:15 /boot/modules/i915kms.ko

On the non working one;

$ ls -l /boot/kernel/i915kms.ko
-r-xr-xr-x  2 root  wheel  969464 Nov  1  2019 /boot/kernel/i915kms.ko

So it looks like the older driver is related to the issue.

$ dmesg| grep CPU
CPU: Intel(R) Core(TM) i5-4570T CPU @ 2.90GHz (2893.38-MHz K8-class CPU)
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
cpu0: <ACPI CPU> on acpi0

Any tips on how to get the new driver / module installed?


More information about the freebsd-questions mailing list