Getting around goofy package dependencies
Ronald F. Guilmette
rfg at tristatelogic.com
Thu Jan 2 01:51:12 UTC 2020
I am having a feeling of deja vu because I'm sure I have been here
I need to use a package named p5-Net-IDN-Encode on one of my FreeBSD 12.0
systems. I tried to just install it with pkg add but that didn't work
becaise I had an older version of perl5 installed and p5-Net-IDN-Encode
wanted a newer one.
So I installed the latest per5, i.e. "perl5-5.30.0". I figured that
should make me golden.
Apparently I'm not that lucky, and p5-Net-IDN-Encode appars to want one
very specific version of perl5, i.e. perl5-5.28.2, even though I have
an even newer one. as a result, now when I try to install the
p5-Net-IDN-Encode [ackage, using "pkg install" I get the following
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 2 package(s) will be affected (of 0 checked):
New packages to be INSTALLED:
Number of packages to be installed: 2
I have tried to get around this by invoking "pkg install" with the -f
option, and separately also with the -M option, but neither one made
even the slightest bit of diofference.
So, two questions:
1) Why do neither the -f nor -M options for "pkg install" do what the
corresponding man page seems to say they will do?
2) Why is the package for p5-Net-IDN-Encode configured in a way that
causes it to need *only* and *exactly* perl5-5.28.2, and why doesn't
the configuration of the and p5-Net-IDN-Encode packahe allow me to
install it when have an even newer version fo perl5 installed?
More information about the freebsd-questions