Pkg broken after 11.3 upgrade

Robert Fitzpatrick robert at
Mon Oct 28 17:08:46 UTC 2019

@lbutlr wrote on 10/28/2019 8:33 AM:
> On 28 Oct 2019, at 06:19, Robert Fitzpatrick via freebsd-questions <freebsd-questions at> wrote:
>> After doing an upgrade from 11.2-RELEASE to 11.3-RELEASE, I could no longer login via SSH. When I login from console, there are many packages that generate segmentation faults including pkg when I tried to pkg upgrade openssh or just pkg update...
>> root at db1: ~ # pkg update
>> /usr/lib/ Shared object has no run-time symbol table
>> I tried to deinstall pkg from ports manually and get these same errors when trying to make install afterward. What can I do to get this functional again?
> Did you read the how to update documentation? It seems not.
> You have put yourself in a bad position that it will take some effort to fix. It might be easiest to rollback to 11.2 and start over.
>   freebsd-update rollback
> You COULD try
>    pkg-static upgrade -f

Yes, this appears to work and will try tonight. Sorry, I do need to read 
through all, didn't even know about rollback.



More information about the freebsd-questions mailing list