Pkg broken after 11.3 upgrade

@lbutlr kremels at
Mon Oct 28 12:33:22 UTC 2019

On 28 Oct 2019, at 06:19, Robert Fitzpatrick via freebsd-questions <freebsd-questions at> wrote:
> After doing an upgrade from 11.2-RELEASE to 11.3-RELEASE, I could no longer login via SSH. When I login from console, there are many packages that generate segmentation faults including pkg when I tried to pkg upgrade openssh or just pkg update...
> root at db1: ~ # pkg update
> /usr/lib/ Shared object has no run-time symbol table
> I tried to deinstall pkg from ports manually and get these same errors when trying to make install afterward. What can I do to get this functional again?

Did you read the how to update documentation? It seems not.

You have put yourself in a bad position that it will take some effort to fix. It might be easiest to rollback to 11.2 and start over.

 freebsd-update rollback

You COULD try 

  pkg-static upgrade -f

When the stars threw down their spears And watered heaven with their
tears, Did He smile his work to see? Did He who made the Lamb make thee?

More information about the freebsd-questions mailing list