Freebsd-update upgrade to 12.1

Doug Hardie bc979 at
Thu Nov 7 01:05:22 UTC 2019

I am running a generic system on 12.0.  I did an upgrade to 12.1 today.  The upgrade command worked properly.  The first install worked properly.  The first reboot also worked.  However, the send install appears to have hung.  It has been running for an hour now.  Digging through the various processes I found the following:

2925	su
	2927	freebsd-update install
		4186	sort (bunch of args I didn't capture)
		4187	tr |
		4188	freebsd-update install
			45329	gunzip

The only process top showed was 4188 which was getting about 2% cpu time.  

The system is on a ada0p2 which is a SATA 2 spinner with 384 G available.

During this time the number of used blocks for ada0p2 was growing quite slowly.  It seemed like it was about 100 blocks per minute.  Nothing else was running on the system.  

Now the interesting part:  While I was typing all this in, it finished!  I have never had the userland update take anywhere near an hour before.  Usually it is on the order of 5 minutes.  What was causing this long update time?

-- Doug

More information about the freebsd-questions mailing list