SSH to jail opens host?

Greg Veldman freebsd at
Sat May 4 13:15:24 UTC 2019

On Sat, May 04, 2019 at 08:29:32AM +0200, Dr. Nikolaus Klepp wrote:
> Anno domini 2019 Fri, 3 May 23:09:19 -0700
>  Russell Haley scripsit:
> > Hi,
> > 
> > This is so embarrassing. I've got a bunch of jails that I created some time
> > ago using iocell that work just fine. I've just tried to create a new jail
> > and every time I try to ssh into it, instead of going to the jail, it takes
> > me back to my host.
> > 
> > I say I've created "a" new jail but I've tried this a couple of times now,
> > each with a different ip4_addr. Does anyone know what stupid thing I have
> > missed or done that would cause this?
> > 
> > I can provide more background but I'm not sure what kind of background to
> > give? Any suggestions would be grand.
> Just for clearification: ech jail has it's own address, all addresses are uniq, and the jails sshd is up and running?

And you'll probably also want to set ListenAddress in the
sshd_config on both the host and the jail(s) so that each
daemon only listens on its own host IP.

Greg Veldman
freebsd at

More information about the freebsd-questions mailing list