Synaptics on Panasonic Touchbook CF-C2

Andreas Nilsson andrnils at
Wed Jan 2 07:17:21 UTC 2019

On Wed, Jan 2, 2019, 01:30 Tomasz CEDRO <tomek at wrote:

> Hello world in 2019 :-)
> I cannot make my Touchpad two finger scrolling on CF-C2 Panasonic
> Toughbook. It works on Windows very nice. I have made it work only
> once in Xorg but never again..
> I have tried on 11.2 and 12.0. Both with PSM+MOUSED and
> PSM0+SYNAPTICS. No success.
> As I understand, the old way was to use xf86-input-synaptics. The new
> way is to use PSM with synaptics support enabled and then use moused +
> xf86-input-mouse..?
> I would like to stick to the new way of using PSM kernel driver, then
> moused and sysmouse as mouse input for Xorg.
> The problem is that both PSM nor SYNAPTICS does not seem to recognise
> the device. I get ID 0 for PSM. Tried various flags. No success..
> Any hints welcome :-)
> Tomek
> --
> _______________________________________________
> freebsd-x11 at mailing list
> To unsubscribe, send any mail to "freebsd-x11-unsubscribe at"


I believe psm+moused is the old way. Anyhow, have you set
he.psm.synaptics_support=1 in loader.conf?

Best regards


More information about the freebsd-questions mailing list