Firefox or what?

Polytropon freebsd at
Thu Aug 15 12:51:27 UTC 2019

On Thu, 15 Aug 2019 12:37:05 +0200, hw wrote:
> On Wed, 14 Aug 2019 13:21:18 +0200
> Andrea Venturoli <ml at> wrote:
> > On 8/13/19 11:34 PM, hw wrote:
> > 
> > > After all this, I wouldn't be surprised if FreeBSD-NFS is incompatible
> > > with Centos-NFS.
> > 
> > Sorry, but you didn't say that in your first post.
> It was neither relevant, nor known in the first post.  If Firefox
> generally doesn't work with FreeBSD, that would have been an
> explanation, and that was what I wanted to know.  Seeing that so many
> things are missing from the version FreeBSD uses is not exactly
> encouraging.

What do you consider "missing from FreeBSD's Firefox version"?
Am I reading this correctly?

Given that the FreeBSD version of Firefox version is essentially
the Linux version of Firefox _ported_ to FreeBSD, I cannot imagine
things are "missing" - except maybe those that heavily rely on
Linux mechanisms that don't exist on FreeBSD, but then, the
"Windows" version of Firefox would miss them, too.

> That NFS doesn't work right was unexpected and unknown, and I was
> assuming that NFS is compatible with NFS since anything else doesn't
> make sense.

As others have confirmed their NFS settings are working fully
as expected, you should review your configuration. You already
could confirm that it works among Linux systems, if I remember
correctly. So FreeBSD is "the new part" here. It still leaves
the possibility (!) that "Linux NFS" is broken in a way that
it only works with Linux, and not entirely as expected with
non-Linux systems such as FreeBSD.

I've been running NFS setups with Linux, BSD, and Solaris, but
that way mamy years ago. Maybe things have disimproved since ... ;-)

> > Again, this might be a problem with FreeBSD, a problem in CentOS, a 
> > problem with how you configured them...
> > We cannot tell if you don't provide info.
> > Also, I'd be suprised if this only affected FireFox (which was the 
> > original subject), as several other programs wouldn't work then...
> Firefox was the one I tried to get to work; if others didn't work
> either, I didn't get so far as to find it out other than a while ago
> when it turned out that NFS in FreeBSD sucks because it's incapable of
> exporting directories with the permissions as required.

Could that be a configuration problem?

Again, it would help if you could quickly describe your setup.
What OS is the NFS server? What does it serve? What's the client?
Where does the Firefox binary reside? Where the home directory
of the user that starts it?

> > > Have you tried that?
> > 
> > No.
> > Everything here is FreeBSD based.
> So that is already a difference.

Definitely. Interoperability can lead to the "funniest"
explorations... :-)

> > > What will you do when you run into bug 220004?
> > 
> > I don't know.
> > I'm not using 12 yet: I see .0 releases (of any software) as potentially 
> > immature and buggy and I'm absolutely not switching until 12.1 is
> > out.
> Then why doesn't the documentation warn about this?

Because (1) nobody noticed yet, and (2) because the attitude
to not use .0 software is nothing "standard", but a specific
preference of certain people (who probably have good reasons
to do so). Personally, I've never been bitten by a .0 version
of FreeBSD. I run Firefox successfully on 12.0-p7/i386, but
there is no NFS involved.

> I was trying to
> find out what the recommended stable version is, and that seems to be
> 12 release.  Why call it release when it's still beta?

Because it isn't beta. FreeBSD has strong guidelines in place
that prevent immature software to be released as a -RELEASE
version: alpha, beta, release candidate(s), release version.
But mistakes _can_ happen, and bugs might slip through. That's
what the patches are for. So if you plan a new installation,
you should use the current release, which is 12.0, and after
installation, use freebsd-update to get the available patches.
If you wish to use an older version, that's possible too, and
that would be 11.3, which _also_ has the status of "production
release", so it's _not_ legacy.

More information here:

Or you wait until 12.1, but that's probably not a solution here.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list