Lenovo T420 / Centrino 6300 Wifi regression 11 -> 12 ?

Marco Steinbach coco at executive-computing.de
Fri Aug 2 17:11:35 UTC 2019


Using 11.1-RELEASE/amd64, up to and including 11.3-STABLE/r350505, the
Centrino Ultimate-N 6300 in my T420 works flawlessly.  I was able to
associate (WPA2-PSK, CCMP) and get an IPv4 address via DHCP.

With 12, the 6300 associates, but I don't get an IP address.
Configuring a fixed address also doesn't allow me to communicate with
any other host on the network.

Sniffing on the T420s local wlan0 interface, I can see the machine is
trying to send out dhcp/arp requests, but does not get an answer.

Sniffing on the wireles interface on the AP (Linksys WRT3200ACM
running OpenWRT 18.06.4 r7808-ef686b7292) only shows LLC packets coming
from the T420 -- no dhcp/arp requests.

If I configure a fixed address on the T420, and then ping
that from a host on my copper network, the source ARP shows up in the
T420s ARP table correctly, and IP traffic works as expected between
the two.

I'm using the GENERIC kernel on 11 and 12. I've tried a clean install
of 12-RELEASE to no avail. I've compiled 12-STABLE/r350464 from source,
no change in behaviour. Trying other T420s, trying to connect through a
different WRT3200ACM, also running OpenWRT, didn't help either.

I've searched the mailing lists and the PRs, but couldn't find anything
resembling this -- I ended up randomly trying some of the hints (e.g.
configure -bgscan), but none of them worked for me.

Anyone else having trouble with 12 and the 6300 Wifi in a T420 ?  And
if you don't, please ping me anyway -- that way I know it has
to be something on my end.


ifconfig_wlan0="WPA ssid ABC SYNCDHCP"

Boilerplate wpa_supplicant.conf:


MfG CoCo

More information about the freebsd-questions mailing list