How determine if a process is running with the proper privilege (dovecot auth issues)

Patrick Mahan plmahan at
Sun Apr 28 23:12:59 UTC 2019


I have been (slowly) tracking down why my dovecot stopped working once I
switched over to using postfix instead of sendmail.  My problem seems to be
that when my mail client (thunderbird) attempts to access the mail using
port 993 (imaps) it is failing to authenticate me.

I am using PAM authentication and when pam_unix:pam_sm_authenticate() is
called for my username, the pw_passwd entry is '*' and not the actual
password entry seen in master.passwd.

I wrote a quick test program using getpwnam() and crypt() and I have found
that if I run it as a normal user it fails exactly the same way that I am
seeing dovecot + PAM fail.  If instead, I run my test program as root, it

So my suspicion is that the dovecot auth is not running privileged, which
is what I am trying to determine, hence the question in the subject line.

Thanks for any pointers.


More information about the freebsd-questions mailing list