any problem going from 9.x (don't laugh) to 11 directly?

Doug Hardie bc979 at
Wed Feb 14 23:42:02 UTC 2018

> On 14 February 2018, at 15:29, Randal L. Schwartz <merlyn at> wrote:
>>>>>> "Doug" == Doug Hardie <bc979 at> writes:
> Doug>   FreeBSD 9.1 cannot use freebsd-update to go directly to
> Doug> 11.x.
> I'm on 9.3, and intended to use freebsd-update.

I'll look around for that patch.  I seem to recall one of my 9.3 systems needed it.  You know if you need it if freebsd-update says cowardly refusing to proceed.  

> Doug> During the upgrade process when you first reboot, you really need
> Doug> to boot in single user mode.
> Doug>   I have always done a regular boot as
> Doug> the machines were not local and had no access to the console.
> I don't think you mean serial console... Arpnetworks gives me a VNC
> console... I presume I can boot single user from the initial menu.

I have not used a VNC console, but have used a serial console which was not all that reliable.  I suspect the issue was with the equipment connected to the serial port, not FreeBSD.

> Doug> There are enough library changes that most services just will not
> Doug> start properly and tend to hang.  You are left with a system that
> Doug> is non-responsive.  The one approach I used successfully one time
> Doug> was to comment virtually everything other than sshd out in
> Doug> rc.conf.  You have to make sure you have really killed sendmail
> Doug> though.  Setting it to NO is not enough.  Otherwise it will
> Doug> eventually give up and give you back service, but it takes a long
> Doug> time.
> Great advice!  Thanks.

I tried to upgrade one system from 9.3 to 10.something and it would not boot.  It died during the hardware discovery.  I gave up and went to 11.0 which worked just fine on that hardware.

-- Doug

More information about the freebsd-questions mailing list